Blue Traxx Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
ok, i thought my chain was just loose but then i later tighten it. start the bike up and when i let go of the clutch and give it gas it starts jolting and the chain starts skipping or at least i think its the chain. any advice on how to fix this problem?
 

·
Registered
Joined
·
20 Posts
check the sprockets? not sure dont even have my first warrior running yet. i would check the sprockets first though and if theyre all intact maybe your chain stretched out. or possibly wheel bearings. again im not positive but thats the best i can think of
 

·
Registered
Joined
·
574 Posts
probably wore out sprockets. Check them and see, if they are always replace both sprockets and the chain at the same time.
 

·
Registered
Joined
·
41 Posts
It might be the axle bearing thats what happened to my warrior and it would grind and make all kinds of noises and the chain would not stay tight but if you can chuck your axle up and down and back and fourth and it is really loose i wouldn't ride it until the bearing are replaceed if that is the case but my rear sprocket is shot also
 

·
Registered
Joined
·
199 Posts
You ask the same question multiple times. Why?

I already told you that you sprockets are most likely shot and need replacing.

Have someone watch the chain next time you try to take off and see if the chain's spinning.

Or better yet, post up a picture of your rear sprocket.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #7
You ask the same question multiple times. Why?

I already told you that you sprockets are most likely shot and need replacing.

Have someone watch the chain next time you try to take off and see if the chain's spinning.

Or better yet, post up a picture of your rear sprocket.
i got new chain set with sprockets and all i need now is a starter relay, thanks for the help
 
1 - 7 of 7 Posts
Top