Blue Traxx Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
hi im new to the forum, and have a question with my warrior. i bought it from a friend with a no start problem. got that fixed with a new stator. it ran and idles fine. give it gas and it pops and sounds like its flooding out. cleaned carb- no better. it does have k&n air filter, and full dg exhaust. stock jets as far as i know. is this a jetting issue, timing issue or neither? i did time the engine properly but could the key be broken for the flywheel causing the crank and cam spin differently? after timing it i started it and it raced, no popping or anything. adjusted the carb and now the pop issue. please help!:???:
 

·
Registered
Joined
·
14 Posts
Sounds to me like a broken flywheel key. I would pull the flywheel and check that out. I had one break on mine with similar problems. Just be careful because you can wear the taper on the crank and flywheel.
 

·
Registered
Joined
·
1 Posts
Alright maybe i shouldnt ask this here but i dont know how to start a new post.My son has a 2007 Yamaha Grizzly 80 I have had quite a bit of carb trouble with it just put the 3rd in it drained the gas put fresh in it.Riding it today it bogged out and cut off now it cranks but wont start i tried starting fluid thinking maybe it was the carb again no luck pulled the plug wire and cranked it in the dark thinking i would see a spark from the wire to the plug nothing.Now this grizzly probably has less than a 100 hours what do you all think?
 

·
Registered
Joined
·
7 Posts
Alright maybe i shouldnt ask this here but i dont know how to start a new post.My son has a 2007 Yamaha Grizzly 80 I have had quite a bit of carb trouble with it just put the 3rd in it drained the gas put fresh in it.Riding it today it bogged out and cut off now it cranks but wont start i tried starting fluid thinking maybe it was the carb again no luck pulled the plug wire and cranked it in the dark thinking i would see a spark from the wire to the plug nothing.Now this grizzly probably has less than a 100 hours what do you all think?
Check the grounds. I had the same issue when I rebuilt my kids xr70r. Turns out the ground under the tank was not making connection. fixed it and it fired first kick.
 

·
Registered
Joined
·
75 Posts
quads

hi im new to the forum, and have a question with my warrior. i bought it from a friend with a no start problem. got that fixed with a new stator. it ran and idles fine. give it gas and it pops and sounds like its flooding out. cleaned carb- no better. it does have k&n air filter, and full dg exhaust. stock jets as far as i know. is this a jetting issue, timing issue or neither? i did time the engine properly but could the key be broken for the flywheel causing the crank and cam spin differently? after timing it i started it and it raced, no popping or anything. adjusted the carb and now the pop issue. please help!:???:
welcome to the wonderful world of Warriors--(wOrriers):bummer:
 
1 - 7 of 7 Posts
Top