Blue Traxx Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I just purchased a 2005 raptor 660r. It came with a curtis sparks x6 full exhaust and a pro flow air filter. The jets are 25 pilots and 167.5L/177.5R mains. Now the problem is that when I start it, the idle seems way too high. My headers then start to glow within seconds and I get constant popping and backfiring from the exhaust. I tried messing with the idle screw to bring it down a bit but I didn't notice a difference. It starts right away and stays on and actually runs good but the backfiring is getting annoying plus I keep burning my riding pants. Another thing is that my reverse light blinks on and off within a few seconds of starting it and only goes away when i put it in gear. Is this normal or is this something that needs to be checked out?? Any help would be appreciated!
 

·
Registered
Joined
·
12 Posts
yes go 3 turns mine was doing the same thing at 2 turns backed them out to 3 turns and the back fire went away you might need to change the needles if that dont work
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
i backed the needles out 3 turns and it still backfires a little, mostly during deceleration. So it did help a little but the pipes are still glowing bright red and my idle still seems high. its getting frustrating, almost tempted to go back stock since the previous owner gave me all the stock parts. If i did decide to go back to stock would i just put the old exhaust and air cleaner along with the 22.5 pilots and 140L/145R mains?
 

·
Moderator
Joined
·
8,530 Posts
If you adjusted and it made a difference, and you are 3 turns out, you need to step up to 27.5 pilots. Make sure the carbs are clean, the pilot circuits are the first to get plugged.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
i backed out the fuel screw another 1/4 turn and the backfire is almost gone. Im gonna try the 27.5 pilots like "diggerzmound" said and hopefully that works cuz my idle is still too high. Should I have the valves adjusted? Could this be a problem? When I ride it rides good but when i pull on the clutch to change gears it revs up really high. Any ideas?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
alright guys well i figured it out!! FINALLY!! You guys were a big help. I did everything u guys said and now the backfiring is gone. I still had the high idle problem but it turned out to be the throttle cable. I gave it some slack and now I can adjust my idle so now the raptor runs perfect as far as i can tell. No more backfire, no more glowing pipes, and no more high idle!! Thanks guys! Now is there a post for changing brake pads?
 

·
Registered
Joined
·
1 Posts
660 raptor running rough

glad it helped
i have an 03 660 raptor.Has sat for 2 years. Drained the gas and carbs and got it running. When it idles it is alright but touch throittle and it back fires. That smartened up but pipe gets real red just reving it up. as soon as you crack it wide open it is just sputtering. Should i take carbs apart and clean? plugged jets i asume?
 
1 - 11 of 11 Posts
Top