Blue Traxx Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I've got a 2006 Yamaha banshee it's got fmf fatty pipes and silencers, boost bottle,k&n air filter and tors removal kit and it ran awesome all year and now that the weathers a bit cooler it has no power in the lower gears sometimes in 5th your can hit the power band a bit but other then that it feels like it's running on one cylinder I changed my plugs and nothing changed so I'm gonna try different jets what size should I get? Please help!!!!
 

·
Registered
Joined
·
2,406 Posts
i am not a 2 stroke guy but unless you have had a huge drop in temp where you live i would not start with the jetting. do a compression test you could have a bad ring. an electrical problem would be at the top of my suspicion list, test your primary coils and triggers. i have never even been on a banshee let alone worked on one but i assume there is some sort of splitter for the throttle cable. is it possible one of the cables is out of adjustment causing the carbs to be out of sync. again i am far from a banshee pro but i ran 2 strokes 20 some odd years ago and i ran the same jetting winter and summer. hope this helps a little
 

·
Super Moderator
Joined
·
8,577 Posts
Double check your carb boots make sure there are no cracks. Temp changes shouldn't affect jetting unless it was on the edge any way, as cory said.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
thanks for the response.
I checked if my carbs are sync'd and they are and there has been a pretty good drop in temp. Yesterday a turned my air flow screw on the carb up quite a bit and that did help with the bogging abit but its still not the way it used to be?
 
1 - 8 of 8 Posts
Top