Blue Traxx Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
Ok i got my raptor like a month a ago so therefore i am still breaking it in. Today i checked the oil and i was almost to the low mark and was wondering why? It isnt leaking anywhere and its still new. Well i dont ever remember having to add oil to my warrior when i bought that new so i was wondering why it may be? any suggestions would be appreciated Thanks
 

·
Registered
Joined
·
530 Posts
are you checking it the right way??? it might sound stupid but your suposed to let it run for a min or 2 and then let it sit for another 2 min then check it...plus ever since i had my raptor i never got the same reading more than once...its always changing on me and i know im not buring it up....so i do as i told you and jsut make sure its full before riding............i just remembered something is that the oil that you put it or the oil that came in it??? becasue when i got mine the stupid dealer had it low i had to add oil right away in mine..so theres something to think about.

<font size=-1>[ This Message was edited by: kfickel on 2001-12-02 16:47 ]</font>
 

·
Registered
Joined
·
37 Posts
Discussion Starter #3
yeah i let it warm up for a couple minutes and let it cool for a couple and checked it and didnt screw the dipstick like it says not to and the dealer is the one that put the oil in it to begin with not me
 

·
Registered
Joined
·
660 Posts
I have had the same probs checking the oil in
my Raptor check it when it is hot you will
get a more Realistc Reading this way after
the oil is hot.
 

·
Registered
Joined
·
660 Posts
Well in this case i would say put some oil
in it just a little at a time keep doing test until your sure the oil level is correct?
 
1 - 6 of 6 Posts
Top