Blue Traxx Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
Whats the cause of leaking oil from the little hole on the right side of the cylinder head, and whats the motive of this little hole.
Thanks
 

·
Registered
Joined
·
175 Posts
If you talking about the hole on the upper front right hand side you may be referring to the Decompresion plug. If so this is any easy fix.... buy the replacement plug from ThumperTalk and it is advertised on this very home page. If this is not what you are referring to and have not yet replaced this plug I would recommend you do ASAP. It will eventually blow and will ruin a perfectly good ride/trip.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #3
I already do that, I mean the Little hole on the rightside, over the header protection plate, its like a draining hole, but its allways dropping oil on mine, I guess very slow cause the oil level in the tank its not going down.
 

·
Registered
Joined
·
17 Posts
The hole your talking about is just a drain hole for the sparkplug tube. it may just be muddy water coming out of this hole. the only way it could be oil is if you sparkplug is loose, and your rings are bad and leaking oil around the base of the spark plug..that is very unlikly though. clean the hole out with a wire and flush it good with water to get the mud out of the sparkplug tube and you should be fine. clean out that hole every time you wash the quad to keep dirt and water from building up around your sparkplug and coil. :tup:
 

·
Registered
Joined
·
80 Posts
Discussion Starter #6
someone knows if its another way for the oil to come out from that spark plug tube drain hole, because Im sure the spark plug its well tight.
 

·
Registered
Joined
·
195 Posts
I had the exact same thing with my 660r. Yes, it is a drain hole for the spark plug. On my raptor the cam spun in the cam jurnals, melted some of the metal away, and oil was escaping through that exact hole. Pull your valve cover off and look. If that is what it is, :tdown: bad news. You will need BOTH valve cover and matching head. Let me know.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #9
I'll check that, thanks, I'll let you know
 

·
Registered
Joined
·
80 Posts
Discussion Starter #12
I forgot to tell you, the problem was a bad oil hose connection on the top head, beside the spark plug, it was leaking oil and going in to the spark plug tube, when I saw that I was like :wtf: :lmao: :lol: :roll: . uff!, before I noted that I checked the top head cover gasket but it was ok, then when putting back the head cover.. what da..! :s96: :lol: . Very expressive!
Thanks for the help!
 
1 - 12 of 12 Posts
Top