Blue Traxx Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
685 Posts
Discussion Starter #1
Hey how do you check the float heights on stock banshee carbs? is it just like checking the ones on the blaster since there pretty much teh same carb? I think my level might be off because when its just warming up it poors gas out. Also what jets do you think i should be running for Ohio (altitute i think around 1500) stock carbs mild porting .020 over fmf fatties with powercore2's shortened some kinda aftermarket reeds and spacer and boost bottle and k&n with proflow. it has 220's for the main ( pretty sure thats stock) but what i dont get is how it had them and it ran like a mother trucker. all of a sudden when it got cold out i ran it it wasnt running 2bad but it jetting was off you could tell and it dies out and one plug was rich (right i think) and the other was a little lean (left) so i dunno whats up help me out if ya can thanks
 

·
Registered
Joined
·
1,004 Posts
sry man i can understand that
to measure floats u take a ruler and from where the gasket goes to the tops of the black float in a relaxed postion same as blaster
 

·
Premium Member
Joined
·
4,210 Posts
Thats how you do it.
But you are way way low for jetting.
BTW, wheres bloomingdale OH? Sounds close, anywhere near Toledo?
 

·
Registered
Joined
·
1,519 Posts
It was running like a mother trucker with 220s because you are lean as hell which means ALOT of power ... but in a bad way
 

·
Registered
Joined
·
685 Posts
Discussion Starter #5
no it wasnt lean one bit i checked the plugs and it was the perfect tan color :roll: that confused the hell outta me what should the height be? does anyone know? or is the same as a blaster and if its off how do you adjust them?
 

·
Registered
Joined
·
685 Posts
Discussion Starter #6
all and warrior- man im about 3- 3 1/2 hours from toledo im right on the ohio river near WestVirginia and Penn. About 45 minutes West of Pittsburgh PA
 

·
Registered
Joined
·
213 Posts
If you have porting, pipes, filter, and different reeds, running 220's trust us you are WAY too lean. Go with 320's and see where your at from there.
 

·
Registered
Joined
·
685 Posts
Discussion Starter #8
i trust you guys lol but believe me it wasnt running lean at all i dunno how the hell it was doing that with those jets in there but the plugs were the perfect tan color and believe me im not new 2 the 2 stroke jetting game lol the thing is just a pain 2 start thats my problem right now
 

·
Registered
Joined
·
134 Posts
220 mains are way too lean you are gonna smoke your pistons
 

·
Registered
Joined
·
132 Posts
LOL

when you buy fatties they give you 280 mains. assuming you have stock carbs and half your air intake isnt blocked off i would put in at least 280's regardless of what the plugs look like. i just got a 2-1 manifold but i had .02 over after marker foam filter fattys/power core 2's.

you may have an air leak on one side have you tried spraying starter fluid around the carbs and intake? thats what i would do. do a leak down test if you get the chance, that will tell you.
 

·
Registered
Joined
·
685 Posts
Discussion Starter #11
well the jets are fine jetting is fine no airleaks i found out the problem thanks for the help
 

·
Registered
Joined
·
273 Posts
FBRacing80 said:
i trust you guys lol but believe me it wasnt running lean at all i dunno how the hell it was doing that with those jets in there but the plugs were the perfect tan color and believe me im not new 2 the 2 stroke jetting game lol the thing is just a pain 2 start thats my problem right now
Hey Man i had the same problem!! My Banshee plugs looked great for a couple week with 260's then i Took it down south and it started to miss so I brought it back home to Ohio!! And rode it around then took the plugs out and they looked great then i rode a lil more and it started to miss again!! So i checked the plugs when i got home and they were lean!! What was ur conclusion to hte problem!!
 

·
Registered
Joined
·
685 Posts
Discussion Starter #13
well about the jetting i dunno but my bike needs reringed and its gettin blow by so it started 2 run lean but thats why mines so hard 2 start cause it needs re ringed dont trust anyone when you buy something :s96:
 
1 - 13 of 13 Posts
Top