Blue Traxx Forum banner

problems

  1. Yamaha YFM350 Raptor/Warrior ('87-Present)
    Hello everyone, I am new to the Fourms here and I really need some help with my bike. I was recently riding and turned my bike off about 2 hours into the ride for a break. After the break I started my bike up but as soon as I went to take off the bike acted like it was under load and stalled...
  2. Yamaha YFM350 Raptor/Warrior ('87-Present)
    I just picked up a 2001 Yamaha Warrior 350, its fast and i love it but there seems to be some pretty interesting things going on with the reverse, and its 100% not possible to find neutral while it is running at a dead stop but i can find it while its rolling..? first problem im not liking the...
  3. Yamaha YFM350 Raptor/Warrior ('87-Present)
    I have a slight issue with my warrior. It latley seems to sputter in last gear when I pin it out. Don't pin it out to often but when I do I started noticing it. Didn't used to do that before. Oil changed and filters cleaned, plug changed so I'm not sure what it is. It does have a yoshimura...
  4. Yamaha YFM350 Raptor/Warrior ('87-Present)
    Today i got new hand grips for my 03 yamaha warrior and i put them on and there was a big gap between my grips and the thing that has the heads lights and start button on it. So i loosened that and slid it over until it touched the hand grips and then i pulled the clutch lever and it was hiting...
  5. Yamaha YFM350 Raptor/Warrior ('87-Present)
    I recently put a new engine on my warrior but I used the older stator on it. Could this be the reason why I have no spark? N also wen I press my start button my selenoid clicks but it doesn't turn over the starter but if I jump the selenoid (wire to positive terminal n starter side of selenoid)...
Top