2010 raptor 700r - Yamaha ATV Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 01-15-2020, 01:37 PM Thread Starter
Junior Member
 
Join Date: Jan 2020
Posts: 2
2010 raptor 700r

im new here, and looking for some help. my raptor runs great when at an idle. in 1st and 2nd gear its good then when i hit it in 3rd it falls on its face. bogs acts like its not getting enough gas. i changed the sparkplug checked the rev limiter. what else could it be please help
kslupe is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-15-2020, 02:34 PM
Senior Member
 
Join Date: Feb 2015
Location: southern oregon
Posts: 1,971
Garage
is the air filter good? fuel pump and filter clean and working? clutch adjusted? is the pipe clogged ? i dont work on fuel injected bikes but it must have a mas air flow sensor check that. you may have to get a tuner and plug it in to see what it needs
cory52000 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome