starter button/ kill switch not working - Yamaha ATV Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 05-24-2019, 02:16 AM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 2
starter button/ kill switch not working

New to the forum. Been doing a lot of reading but havent came across a problem exactly like mine.
I recently bought a 2004 Raptor 660 it was sitting for a long time A lot of it was a part put it all back together. The battery held a charge. put new starter solenoid on, patched up a few wires cleaned out the carburetors, headlights work brake lights work all the lights, neutral, reverse lights all come on when I push starter button but nothing happens when I cross it at the solenoid it starts right up but will not shut off with kill switch must turn fuel off and run out of gas or pop the clutch to turn it off I checked the starter switch on the left side handlebars it's all clean almost looks brand new I am not sure if my solenoid is exactly wired correctly I will attach a picture of how it was when I got it I recently bought a new solenoid and cleaned up positive and negative battery terminals and put new solenoid on the way it was when I received it someone you please help me thank you. This is how it was wired up so with a new solenoid I wired it the same way, is this correct in the picture or no? Please help asap
Attached Images
File Type: jpg Screenshot_20190524-024940_Gallery_1558682153877.jpg (573.2 KB, 2 views)
Rappuk007 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-24-2019, 11:11 AM
Senior Member
 
Join Date: Feb 2015
Location: southern oregon
Posts: 1,855
Garage
first the start and kill are most likely 2 separate issues check and clean the plug on the cdi that is the only thing i can think of that would cause both issues.
i dont have a wiring diagram handy for the 660 so you will have to google it or order the clymer manual. on of the small wires should have 12 volts when you press the button and nothing when you let it go. if you get 12 volts to one of those wires and it does not crank i would suspect they are hooked up wrong but you would need to confirm it with a wiring diagram. i found tons of them on google. if no signal is getting through you will need to rule out the start button, and safety switches.
as to not shutting off i suspect a bad ground (it could be causing you no start issue as well) there should be a large ground wire from the battery to the engine and a small black wire from the battery cable to the wiring harness.
i wish there was a magic bullet i could give you for this but you are going to need to get a good wiring diagram and start tracing wires. i suspect you will find a short or bad connection. cranking running and shutting of are all separate circuits. since it run if you jump the solenoid the run circuit is good and you will need to figure out why the start signal is not getting from the battery to the solenoid. start at the battery and trace the power to and through the switch.
the kill switch just ground the ignition circuit either at the switch or the key.
cory52000 is offline  
post #3 of 4 Old 05-28-2019, 10:35 PM
Junior Member
 
Join Date: May 2019
Posts: 1
these have a choke?

i have never seen a choke on mine, 99 Warrior.

i want to do jets but know absolutely nothing about this stuff.
speeding-g60 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 05-29-2019, 09:08 AM
Senior Member
 
Join Date: Feb 2015
Location: southern oregon
Posts: 1,855
Garage
speeding to start with you are in the raptor section and if you are asking if they have a choke then yes. it is technically an enrichener but to the average rider it means the same thing. ( a choke decreases the amount of air in the mix to make the mixture richer and easier to start, an enrichener adds fuel to do the same thing).

if you just posted in the wrong section and are asking about your warrior, they have an enrichener as well. it is a black button on the side of the carb.



in a nut shell you change your jet sizes to adjust for elevation and other factors that effect the fuel to air mixture. without a significant change to the machine or elevation jetting is not something you just "do". why do you think you need to change your jetting? have you replaced your plug, ran the machine for a while and then checked your plug? any recent mods? elevation change
cory52000 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 Yamaha Warrior clicking starter relay and reverse wire gandl2123 Yamaha YFM350 Raptor/Warrior ('87-Present) 2 04-21-2018 07:28 PM
04 Warrior Kill Switch Bypass??? Sublime69 Yamaha YFM350 Raptor/Warrior ('87-Present) 2 10-05-2017 10:37 AM
Kill switch and key switch.need help Spencers_atv Yamaha YFZ450/450R (2004-Present) 2 09-15-2017 06:15 PM
white kill switch relay wiring blaster105 Yamaha Wolverine 350 / 450 0 05-06-2016 07:57 PM
Warrior starter grinding Barnsnelbon Yamaha YFM350 Raptor/Warrior ('87-Present) 4 12-13-2015 10:09 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome