87 Warrior, no spark while cranking - Yamaha ATV Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 01-19-2019, 11:15 AM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 1
87 Warrior, no spark while cranking

I just recently got an 87 warrior off of a neighbor. It has new coil, cdi, pickup coil and stator. While cranking I have no spark. But I get a spark or two as soon as I release my start button... thoughts?
LKeney is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 01-21-2019, 07:23 PM
Senior Member
 
Join Date: Feb 2015
Location: southern oregon
Posts: 1,853
Garage
if it has a new cdi it is either not an 87 or its a used one they dont make a cdi for the 87s. if you bought the Chinese stuff you will need to test it all to see if its bad out of the box. probably a bad stator or one of the pickups
cory52000 is offline  
post #3 of 3 Old 01-29-2019, 07:39 PM
Junior Member
 
Join Date: Sep 2018
Posts: 18
probably bad or wrong ign switch. New CDIs ARE availiable for ALL the old early Yamaha ATVs. https://cdiparts.com/
tom bauer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
No spark RevNate Yamaha YFM350 Raptor/Warrior ('87-Present) 2 08-30-2018 11:41 AM
OE cdi box, no spark, aftermarket has spark but won't start with button. Bwoody Yamaha YFM350 Raptor/Warrior ('87-Present) 7 02-07-2017 08:23 PM
Please help!! 86 Moto 4 80cc NO SPARK Rnunnelly Other Models/Brands 20 08-23-2016 07:39 AM
Yamaha terrapro yfp350 spark plug issues rsmitty1000 Other Models/Brands 1 06-13-2016 10:15 AM
2009 Have Spark but not at Start BAMAJiPS Yamaha YFM350 Raptor/Warrior ('87-Present) 40 04-09-2016 07:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome