Clutch wont engage! - Yamaha ATV Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 02-05-2003, 01:50 PM Thread Starter
Junior Member
 
Join Date: Aug 2002
Posts: 13
Clutch wont engage!

Heres the deal, I got a 1989 warrior and now I cant engage the clutch. I tightened the play in the lever and its tight, theres good pressure on it too. I even opened up the case and took a look at the clutch, everything looks good. Any tips would be great.
JOJO is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 02-05-2003, 06:31 PM
Senior Member
 
Join Date: Jun 2002
Location: Pittsfield, MA
Posts: 427
Take it apart and put it back together. The problem is the pressure plate is out place. Get a Clymer manual to help you along.

2006 YFZ450
Stock but lots to come in time
Warrior548 is offline  
post #3 of 11 Old 02-05-2003, 08:41 PM
Primo Member
 
Join Date: Jun 2002
Location: Oklafreakinhoma
Posts: 501
Quote:
Originally Posted by Warrior548
Take it apart and put it back together. The problem is the pressure plate is out place. Get a Clymer manual to help you along.
Or just download the PDF version of the Factory Service manual from the Raptor 660 forum.... for FREE.
HubMonkey is offline  
Sponsored Links
Advertisement
 
post #4 of 11 Old 02-09-2003, 09:56 PM
Senior Member
 
Join Date: Mar 2002
Location: South Jersey (sicklerville)
Posts: 629
Send a message via AIM to BLKnREDwarrior
Definately get a Clymer, the best $30 i spent hands down. While your in there taking apart your clutch i would swap out the stock springs for some stiffer ones ($13 from alba) so you dont have to worry about your clutch slipping and get all the power to the ground.

93 Warrior, 500cc FST, black & red cut fenders, HMF pipe, K&N, realtors, kenda fronts, AC mudscreen, green headlights, polished covers, modified cluth perch, dominator bars, WB block off SOLD!!!
BLKnREDwarrior is offline  
post #5 of 11 Old 02-09-2003, 11:11 PM
Senior Member
 
Join Date: Aug 2002
Posts: 194
You wrote that you cant engauge the clutch, Meaning it will not pull the rear wheels. My 94 Warrior came like this when I bought it 6 moths ago. Who ever put mine back together placed lower the clutch arm in the wrong position. You must have a little free play in the cable for it to work properly. The pull or tension is what disengauges the clutch. You might try disconnecting the lower arm from the cable and repositioning it, rotating it clock wise a tooth or two, so that the cable has more free play. Other than that the clutch could be shot. I'm sure there are other seniaros but these are the two I faced...

Michael
whitfimb is offline  
post #6 of 11 Old 02-23-2003, 01:21 PM Thread Starter
Junior Member
 
Join Date: Aug 2002
Posts: 13
Well i took the clutch apart, lubed up the discs and put er back together, and now she engages again. Now if only the carb kit I ordered 4 months ago would come in I would be a happy man. %$^% you KIMPEX!!
JOJO is offline  
post #7 of 11 Old 02-23-2003, 02:27 PM
Senior Member
 
Join Date: Aug 2002
Posts: 194
Wow! My deal is usually only 4-days out on special orders. Where did you get your carb kit from?
whitfimb is offline  
post #8 of 11 Old 03-04-2003, 09:42 PM Thread Starter
Junior Member
 
Join Date: Aug 2002
Posts: 13
first i ordered it from a yamaha dealer, it was back ordered for a bit then it still never came in, I kept calling, they kept saying, it'll be in tommorow. After about a month i ordered it from the place that i started working for. That order got lost along with a whole crap load of helmets, now its reordered so I guess we'll see eh?
JOJO is offline  
post #9 of 11 Old 03-05-2003, 08:02 AM
Senior Member
 
Join Date: Feb 2003
Location: Michigan
Posts: 307
Send a message via AIM to TheGreenGrizzly
That sucks man

2001 Yamaha Banshee - Douglass Rims, Fast Trekkers, Boost Bottle, Pro Air Filter, Wheel Spacers

Check out my wicked site:
http://www.jquad.cjb.net
TheGreenGrizzly is offline  
post #10 of 11 Old 03-21-2003, 07:32 PM Thread Starter
Junior Member
 
Join Date: Aug 2002
Posts: 13
Finally, the carb kit came in, and now at last, I am a happy man!
JOJO is offline  
post #11 of 11 Old 03-21-2003, 07:56 PM
Senior Member
 
Join Date: Feb 2003
Location: Nebraska
Posts: 554
Send a message via AIM to WarriorRacer
Good
WarriorRacer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
clutch wont engage warrior777 Yamaha YFS200 Blaster ('88-Present) 24 06-05-2018 12:04 PM
New clutch will not engage!!! help raptrax Yamaha YFM660R Raptor (2001-2005) 7 02-13-2007 10:37 PM
new clutch won't engage. Raptorjack Yamaha YFM660R Raptor (2001-2005) 1 05-13-2005 10:16 AM
raptor clutch won't engage problem nhearnest Yamaha YFM660R Raptor (2001-2005) 4 03-19-2004 09:05 PM
New Clutch..... Wont Shift MASTERBLASTER69 Yamaha YFS200 Blaster ('88-Present) 0 02-01-2003 09:37 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome