1986 Yamaha Moto4 225 stuck in Neutral - Yamaha ATV Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-01-2019, 03:13 PM Thread Starter
Junior Member
 
Join Date: Feb 2019
Posts: 1
1986 Yamaha Moto4 225 stuck in Neutral

Rescued this thing from sitting in a warehouse the last two decades. Finally got it to fire, but when I put it into neutral to do so its now stuck in neutral, and wont shift no matter how much pushing, rocking, etc. Even with throttle it wont. Range lever on left side will go from H to L, but not to R, and this makes no difference on it being stuck in neutral.

Any suggestions?
Chris Moceri is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 02-01-2019, 08:43 PM
Senior Member
 
Join Date: Feb 2015
Location: southern oregon
Posts: 1,872
Garage
i would say something in the clutch or trans is corroded and needs cleaned. or you just figured out why it was parked 2 decades ago
cory52000 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome