Warrior Clutch Problems. 02' - Yamaha ATV Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 12-22-2010, 10:59 PM Thread Starter
Junior Member
 
Join Date: Dec 2010
Posts: 1
oops Warrior Clutch Problems. 02'

My Clutch is adjusted all the way out and it catches at the very end of the lever play. Also its a pain to go from reverse to forward and getting into nuetral when running hot. Any ideas on how to fix? do i need a new clutch?
trd0820 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 12-23-2010, 08:08 AM
Crowd Control
 
diggerzmound's Avatar
 
Join Date: Oct 2002
Location: Nebraska
Posts: 8,406
Garage
Send a message via AIM to diggerzmound Send a message via Yahoo to diggerzmound
Install a new clutch.

01' Raptor 720, Stage 2, FCR'd
97' 250 Vitos Blaster
06' Rhino 450
94' Banshee T-5's, Vforce, ported, Cool Head, 2-1
06' Wolverine 450 - Stock!
06' LTZ 440
94' Vmax4 750, 96' 600 MountainMax
06' Vmax 1200
diggerzmound is offline  
post #3 of 5 Old 12-23-2010, 01:14 PM
Member
 
$nowman's Avatar
 
Join Date: Oct 2010
Location: BC, Canada
Posts: 83
Quote:
Originally Posted by trd0820 View Post
My Clutch is adjusted all the way out and it catches at the very end of the lever play. Also its a pain to go from reverse to forward and getting into nuetral when running hot. Any ideas on how to fix? do i need a new clutch?


sounds like you need a new clutch and springs... change your oil and filter, use synthetic. i rock mine back & forth on the trail its easier to get it in and out of gear.
$nowman is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 12-24-2010, 09:22 PM
Senior Member
 
Join Date: Apr 2010
Posts: 161
your cable may just be stretched. check your abrasives anyway, it can't hurt. btw, make sure the arm is on the shaft properly. i believe it has a dot on the arm and a line on the shaft.
mike75925 is offline  
post #5 of 5 Old 12-30-2010, 11:01 AM
Junior Member
 
Marxican's Avatar
 
Join Date: Dec 2010
Posts: 13
start with a cable its the cheapest, then go with a new clutch if the cable doesnt do it

2004 warrior, fmf power bomb & t4 muffler, dyno jet, k&n, banshee rear shock, and lots of powder coating
Marxican is offline  
Reply

Tags
350 warrior, clutch problems

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Big clutch problems NickyPap Yamaha YFZ350 Banshee (1987-Present) 2 08-31-2005 08:01 AM
clutch problems??help bbradst01 Yamaha YFZ350 Banshee (1987-Present) 4 05-24-2004 11:31 AM
clutch problems primal1 Yamaha YFM350 Raptor/Warrior ('87-Present) 9 04-07-2004 03:17 PM
Clutch problems on an 03 Raptor660rman Yamaha YFM660R Raptor (2001-2005) 12 07-06-2003 11:24 PM
clutch problems raptor4 Yamaha YFM660R Raptor (2001-2005) 1 06-28-2002 07:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome