99 has spark but won't run - Yamaha ATV Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 05-08-2010, 03:41 PM Thread Starter
Junior Member
 
Join Date: May 2010
Posts: 7
99 has spark but won't run

i'm a newbie so here it goes... i just bought a 99 warrior at a good price thinking that it might be worth the time to fix it up. it is getting spark and has good compression, i guess but there is no gas getting to the plug. every once in awhile, backfire but thats about it. i cleaned the carb pretty good and changed the fuel lines and filter put fresh 93gas and still nothing. so now its on ya'll, what can i do to get riding? the guy told me it had been sitting for awhile but idk if i believe him now. he also said it has a big bore kit and stroked w/ a mikuni carb. what is it gonna cost to fix whats wrong?
warrior6952 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 05-08-2010, 10:34 PM
Senior Member
 
Join Date: Apr 2010
Posts: 161
first things first. you have spark and comp, good. is fuel getting through the line and into the carb? there is a bowl drain screw that will tell you if you are getting gas. if your carb has gas, remove your airfilter from the airbox and cover the hole going to the carb. try starting the engine. if it starts and runs by hand choking, it could be one of several issues. the first is whether the carb is clean. some carbs are really easy to clean while others are a major pain. next will be the intake boot between the head and carb. this is tested by restoring the breather assembly and spraying some carb cleaner at the boot while the engine is running. if the engine revs, you have a leak, replace the boot. if not, check your idle set and mix set.
mike75925 is offline  
post #3 of 6 Old 05-10-2010, 02:07 PM Thread Starter
Junior Member
 
Join Date: May 2010
Posts: 7
well i've done all that and more... the carb is spotless, its a mikuni slide carb and its all operating fine. i've tryed to roll start it in 5 or 6 pulling it with the truck but all i get is a bunch of backfire???? its in the shop now being diagnosed so i'll let ya'll kno what they say...
warrior6952 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 05-10-2010, 02:18 PM
Senior Member
 
Join Date: Apr 2010
Posts: 161
make sure they keep ahold of the 'bad' parts. some shops will say this and that are bad, and leave them in place while still charging you for supposed good ones.
mike75925 is offline  
post #5 of 6 Old 05-10-2010, 03:27 PM Thread Starter
Junior Member
 
Join Date: May 2010
Posts: 7
oh i kno this, i've taking parts(stator,coil) to be tested and they tell me its bad but later down the road i find out(cdi) they just wanted to make a couple bucks since i wasnt bringing it to them to do the work

Last edited by warrior6952; 05-10-2010 at 03:31 PM.
warrior6952 is offline  
post #6 of 6 Old 05-12-2010, 10:54 PM
Senior Member
 
Join Date: Apr 2010
Posts: 161
i'm now in the same boat! pos warriors.
mike75925 is offline  
Reply

Tags
carburetor, mikuni, rebuild, spark, warrior

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
No Spark ? Jetstream31 Yamaha YFM660R Raptor (2001-2005) 3 04-03-2012 08:50 PM
No Spark.. tOj Yamaha YFZ350 Banshee (1987-Present) 8 04-13-2007 10:29 AM
No Spark!!! MoRaptor02 Yamaha YFM350 Raptor/Warrior ('87-Present) 4 08-17-2005 10:44 PM
No Spark MoRaptor02 Yamaha YFM350 Raptor/Warrior ('87-Present) 0 08-10-2005 01:29 AM
Spark plug will not spark custom_warrior Yamaha YFM350 Raptor/Warrior ('87-Present) 3 09-22-2003 03:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome