Yamaha Sport ATV Forum

starting questions- 2003 yamaha wolverine 350 4x4

This is a discussion on starting questions- 2003 yamaha wolverine 350 4x4 within the Yamaha Wolverine 350 / 450 forums, part of the Performance /Technical category; hi guys i bought a 2003 wolverine a few weeks ago. i love it. was working fine till i went out the other day in ...


Go Back   Yamaha ATV Forum > Performance /Technical > Yamaha Wolverine 350 / 450

Reply
 
LinkBack Thread Tools Display Modes
Old 11-03-2012, 10:48 PM   #1
Junior Member
 
Join Date: Nov 2012
Posts: 2
View msv268's Photo Gallery(0)
Default starting questions- 2003 yamaha wolverine 350 4x4

hi guys i bought a 2003 wolverine a few weeks ago. i love it. was working fine till i went out the other day in alot of puddles. the electric start button wont work anymore. the gree nuteral light wont light up. if i use the pull start that works fine, once it starts by using pull start the nuteral light lights up.. what shall i check first i wanna be able to use the button. thank you all for your help i appericate it very much


matthew
msv268 is offline   Reply With Quote
Old 11-04-2012, 06:48 PM   #2
Junior Member
 
Join Date: Nov 2012
Posts: 2
View msv268's Photo Gallery(0)
Default

a bunch of readers and no helpers?
msv268 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Yamaha ATV Forum > Performance /Technical > Yamaha Wolverine 350 / 450


Search tags for this page

wolverine pull start

,

2003 yamaha wolverine

,
yamaha wolverine clicks when trying to start
,
2003 yamaha wolverine clicks when trying to start
,
wolverine 350 really hard shifting
,
yamaha wolverine 350 solution for hard starting
,
yamaha wolverine pull starter very hard to pull
,
yamaha wolverine too hard to pull start
,
yamaha wolverine 350 pull start hard
,
350 wolverine yamaha hard to start
,
2003 yamaha wolverine 350 engine clicks alot
,
atv wolverine pulling
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
New to forum/98 Wolverine 350 starting problem Fred1 Yamaha Wolverine 350 / 450 6 03-27-2014 10:31 AM
2003 Raptor Starting Problem JonathanDavos Yamaha YFM660R Raptor (2001-2005) 4 12-23-2006 06:46 PM
Just got a Wolverine, have a few questions. edge Other Models/Brands 4 08-02-2004 10:24 PM
Wolverine Starting problem...check it out screamin96 Other Models/Brands 7 07-28-2003 10:28 PM
wolverine questions tony montana Other Models/Brands 5 01-08-2002 12:51 AM

» Discount Tire
Motosport.com

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 11:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.